Skip to content

docs: require a security-supported PHP for the shared-hosting proxy - #153

Open
dolonet wants to merge 1 commit into
mainfrom
docs/php-supported-branch
Open

dolonet wants to merge 1 commit into
mainfrom
docs/php-supported-branch

Conversation

@dolonet

@dolonet dolonet commented Oct 23, 2026

Copy link
Copy Markdown
Owner
  • Replace the "PHP 5.3+" floor (also inaccurate: http_response_code() needs 5.4) with "a supported branch or a vendor package that still gets security fixes" in README, README.ru and the api.php header.
  • New "Keep PHP patched" section in docs/deployment.md: why this layout makes PHP part of websh's attack surface, why the proxy can't mitigate request-parsing bugs, and what to do without a patched PHP. Both Quick starts link to it.

Motivation: CVE-2026-109618 / CVE-2026-109619 (Oct 2026) — unauthenticated RCE in the PHP interpreter during request handling; fixed in 8.2.35 / 8.3.36 / 8.4.27 / 8.5.12, no upstream fix for 7.3 and older.

Test plan: php -l api.php; tests/php/smoke.sh passes; heading anchors checked.

README promised "PHP 5.3+", which was neither true (api.php calls
http_response_code(), added in 5.4) nor safe: interpreter-level PHP
bugs such as CVE-2026-109618 / CVE-2026-109619 (Oct 2026,
unauthenticated RCE) fire while PHP parses the request, before
api.php runs, and upstream ships no fix at all for 7.3 and older.

Point users at php.net's supported branches (or a vendor package
with backported fixes) instead of a version floor, and add a
"Keep PHP patched" section explaining why this layout makes PHP
part of websh's attack surface and what to do when a patched PHP
isn't available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant