Repository navigation
Problem: The command "import -P eddblink -O listings" generates an error #172
Replies: 4 comments 3 replies
|
The problem is being caused by a station that moves: The station is a "Mega ship" (internal type_id of 13) The old data (i.e., the previous days' nightly dump,) says that station is in 'Synuefe EN-H d11-96'. It is apparent that the ship has moved in between the last dump and the most recent one, and since the prices file was built using the old data (and uses Developer communiqué:The easy solution to this particular problem would be to delete the
The source of this problem is that the (Also, I noticed this while trying to find the cause of this problem: |
|
Sorry, maybe @kfsone wants to say something else, so open again. |
|
It is strange that I have a problem on first trying to update my database but it doesn’t present as an error. Mine tells me that there are two instances of Rescue ship Arc’s Faith and then shows import complete. Re-running the exact command again completes the whole update with no problem. Presumably, the rescue ship is another example of a movable station but nepomuk gets a python error, where I get a jump to the end! Odd! I’m glad there seems to be reason for it - I was seriously considering going to find this rescue ship and attack it!! 🫢 |
|
@eyeonus I don't know anything about the carriers work, except apparently that they appear in the data somehow as stations. Want to make a discussion/ticket for this to soundboard / spitball solutions? |


The problem is being caused by a station that moves:
#Selected station: ZENDE/THE CONDUIT, ID=-1This was determined by running the command with-wand looking at the resulting error report, so thanks to @kfsone for adding the rich format error output, it was very useful in this case.The station is a "Mega ship" (internal type_id of 13)
The old data (i.e., the previous days' nightly dump,) says that station is in 'Synuefe EN-H d11-96'. It is apparent that the ship has moved in between the last dump and the most recent one, and since the prices file was built using the old data (and uses
{system name}\{station name}rather than the station's unique id), that's where the problem comes from.…